XP SP2: "Now that didn't hurt, did it?"

Internet connectivity problem with XP SP2 upgrade solved. Solution? Uninstall. And then a series of remedial steps to finally restore the system to its Friday, 10 Sept 2004, checkpoint. We seem to be back in working order.

The good news about this is that the SP2 uninstall script does seem to have worked. The other good news is that, by some miracle, the original XP Pro system is keeping nightly checkpoints. I'm thinking that this was part of the original install, and I'm glad it was, is.

The somewhat anxiety provoking moments were the following:

1. SP uninstall script claims successful uninstall and says computer needs to be restarted. Click "Finish". Nothing. After a couple of minutes still nothing. I try to use the mouse to close the open windows, but although it moves around there is no connection to the screen. CTL-ALT-DEL brings up the Task Manager. Cool. I try to select the running application; it gets highlighted; I select "End Task"; nada. After a few more insane attempts to do the same thing and hope for a new result I go for the power button.

2. Power down, power up, ..., time passes, ..., start to worry (What if I really have to reinstall the whole OS?) ....

3. Power down, power up. Now I get a diagnostic screen that lets me choose things like "Safe Mode", "Safe Mode with Networking", "Last Known (something)", .... Hmmm .... OK, I want to try networking so let's go with "Safe Mode with Networking." Funking screen filled with DLL names, then a very low resolution screen with writing off the screen. I click the mouse and get a very low resolution window.

4. I'm not sure what happened next, but I'm presented with a screen asking if I'd like to restore the system to a previous checkpoint. This sounds very promising and I go for it, am given a calendar, and choose last Friday. System restore starts and takes maybe 15 minutes.

5. System reboots, gives me a successful restore screen, and I select "OK" and the system lets me login. I choose admin and things do seem to be working like they used to be. So I login as a normal user and things seem to be as they were. The system's back ... I think.

6. Now I'm pretty sure that there's a bunch of renamed files hanging around on that disk, and I have no idea whether everything is working as before, but that system is back on the net and that's good.

7. I think I need to see that I have the latest XP upgrades prior to SP2.

8. Oh, one other factoid. I'm pretty sure that the SP2 problems all stem from the firewall. And even though I had turned it off, the system still recognized that I was running ZoneAlarm, so maybe something else is going to keep the computer secure.

I would love to see the use cases and user interaction scenarios that were used to develop and test this service pack. It's important to use tools like these to construct proposed user interactions and experiences. I hope that these kind of design activities can lead to useful and usable user experiences. But something funky happened with this upgrade and I'm not sure how to describe it.

9. Conclusion: I'm going to wait a while longer before upgrading. I don't really want to spend a lot of time browsing FAQ's and support mail archives. But I'm pretty sure I'm gonna be learning more about the firewall.

Recent Entries

Close